// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)\w+\s*=\s*([\w']+)").unwrap();
let string = "name = 'Bruce Wayne' || TrackId = 12 || age =9 && sample = 7 || thisistoolong = 'asda'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}