re = /\w+\s*=\s*([\w']+)/x
str = 'name = \'Bruce Wayne\' || TrackId = 12 || age =9 && sample = 7 || thisistoolong = \'asda\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end