package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<main>\w+|\*)/(?P<sub>\w+|\*)(\s*;\s*(?P<param>\w+)=\s*=\s*(?P<val>\S+))?`)
var str = `image/jpeg
application/atom+xml
application/EDI-X12
application/xml-dtd
application/zip
application/vnd.openxmlformats-officedocument.presentationml.presentation
video/quicktime
application/json; indent=4
application/json
text/*
*/*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}