import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<main>\\w+|\\*)/(?P<sub>\\w+|\\*)(\\s*;\\s*(?P<param>\\w+)=\\s*=\\s*(?P<val>\\S+))?";
final String string = "image/jpeg\n"
+ "application/atom+xml\n"
+ "application/EDI-X12\n"
+ "application/xml-dtd\n"
+ "application/zip\n"
+ "application/vnd.openxmlformats-officedocument.presentationml.presentation\n"
+ "video/quicktime\n"
+ "application/json; indent=4\n"
+ "application/json\n"
+ "text/*\n"
+ "*/*";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}