const regex = new RegExp('(?P<main>\\w+|\\*)/(?P<sub>\\w+|\\*)(\\s*;\\s*(?P<param>\\w+)=\\s*=\\s*(?P<val>\\S+))?', 'g')
const str = `image/jpeg
application/atom+xml
application/EDI-X12
application/xml-dtd
application/zip
application/vnd.openxmlformats-officedocument.presentationml.presentation
video/quicktime
application/json; indent=4
application/json
text/*
*/*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}