const regex = /<html>(?:(?!<\/html>).)*<\/html\>/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<html>(?:(?!<\\\/html>).)*<\\\/html\\>', 's')
const str = `This is text
<html>
<div>
some content
</div>
</html>
This is more text
<html>
<div>
some content
</div>
</html>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}