re = /<html>(?:(?!<\/html>).)*<\/html\>/
str = 'This is text
<html>
<div>
some content
</div>
</html>
This is more text
<html>
<div>
some content
</div>
</html>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end