$re = '/(?:\+?91-?\d{10})|(?:0?\d{10})(\,(?:\+?91-?\d{10})|(?:0?\d{10}))*/s';
$str = '+919883443344,+91-9883443344,919883443344,91-9883443344,09883445666,9883443344';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);