re = /(?:\+?91-?\d{10})|(?:0?\d{10})(\,(?:\+?91-?\d{10})|(?:0?\d{10}))*/
str = '+919883443344,+91-9883443344,919883443344,91-9883443344,09883445666,9883443344'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end