# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=.*p)(?=.*o.*o)(?=.*u.*u)(?=.*l)(?=.*t.*t)(?=.*r)(?=.*y)(?=.*w)(?=.*i)(?=.*s.*s)(?=.*a)(?=.*n)(\b.{18}\b)//g;t' <<< "pastilsturnouttowy
pastilstowyturnout
towyturnoutpastils
poultryoutwitsants"