import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "nextval\\('([^']*?)'\\:\\:regclass";
final String string = "CREATE TABLE foo (\n"
+ " id INTEGER DEFAULT nextval('foo_id_seq'::regclass) NOT NULL,\n"
+ " bar VARCHAR(100),\n"
+ " baz VARCHAR(100)\n"
+ " CONSTRAINT hvs_pkey PRIMARY KEY (id)\n"
+ ")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}