$re = '/nextval\(\'([^\']*?)\'\:\:regclass/m';
$str = 'CREATE TABLE foo (
id INTEGER DEFAULT nextval(\'foo_id_seq\'::regclass) NOT NULL,
bar VARCHAR(100),
baz VARCHAR(100)
CONSTRAINT hvs_pkey PRIMARY KEY (id)
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);