// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)nextval\('([^']*?)'\:\:regclass").unwrap();
let string = "CREATE TABLE foo (
id INTEGER DEFAULT nextval('foo_id_seq'::regclass) NOT NULL,
bar VARCHAR(100),
baz VARCHAR(100)
CONSTRAINT hvs_pkey PRIMARY KEY (id)
)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}