package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{10}(?:[0-9]{3})?$`)
var str = `123456789
1234567890
12345678901
123456789012
1234567890123
12345678901234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}