$re = '/^[0-9]{10}(?:[0-9]{3})?$/m';
$str = '123456789
1234567890
12345678901
123456789012
1234567890123
12345678901234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);