re = /^[0-9]{10}(?:[0-9]{3})?$/m
str = '123456789
1234567890
12345678901
123456789012
1234567890123
12345678901234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end