using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?#digits)(?<zipcode_digits>\d{4})[\s]?(?#chars)(?<zipcode_chars>\w{2})";
string input = @"1851 KW";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}