const regex = /(?#digits)(?<zipcode_digits>\d{4})[\s]?(?#chars)(?<zipcode_chars>\w{2})/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?#digits)(?<zipcode_digits>\\d{4})[\\s]?(?#chars)(?<zipcode_chars>\\w{2})', 'i')
const str = `1851 KW`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}