package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?#digits)(?<zipcode_digits>\d{4})[\s]?(?#chars)(?<zipcode_chars>\w{2})`)
var str = `1851 KW`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}