using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+)\((\S+)\),(\S+)\((\S+)\)";
string input = @"/dev/sda,1(10),/dev/sdb(0)
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}