const regex = /(\S+)\((\S+)\),(\S+)\((\S+)\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+)\\((\\S+)\\),(\\S+)\\((\\S+)\\)', '')
const str = `/dev/sda,1(10),/dev/sdb(0)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}