$re = '/(\S+)\((\S+)\),(\S+)\((\S+)\)/';
$str = '/dev/sda,1(10),/dev/sdb(0)
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);