using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(rgb)\(([0-9]+),\s+([0-9]+),\s+([0-9]+)";
string input = @"rgba(255, 255, 255)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}