package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(rgb)\(([0-9]+),\s+([0-9]+),\s+([0-9]+)`)
var str = `rgba(255, 255, 255)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}