$re = '/(rgb)\(([0-9]+),\s+([0-9]+),\s+([0-9]+)/';
$str = 'rgba(255, 255, 255)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);