use strict;
my $str = 'base64:= "iVBORw0KGgoAAAANSUhEUgAAAyAAAAJzCAYAAAD3HXeFAAAgAElEQVR4nOy9W3bksI4ECOp6ET2n56dn/1u8yfkgAeJJUbaryo+IUy5nSiQIUuEEFIKU7f/7f/+fTkTUeydqjah3aq0RUSNqRNQ7ddk20Oc2bnO1Rq9XJ27SO9F1XdT7a/RrjfrrRURErbXZl8z7MQZRa9ewwfvneNyutUatNXq9XkTzNb1e1K7hwzRK/TXGbtdFr//+V/pp//
base64:=+V
V
base64:=V
base65 := "iVBORw0KGgoAAAANSUhEUgAAAyAAAAJzCAYAAAD3HXeFAAAgAElEQVR4nOy9W3bksI4ECOp6ET2n56dn/1u8yfkgAeJJUbaryo+IUy5nSiQIUuEEFIKU7f/7f/+fTkTUeydqjah3aq0RUSNqRNQ7ddk20Oc2bnO1Rq9XJ27SO9F1XdT7a/RrjfrrRURErbXZl8z7MQZRa9ewwfvneNyutUatNXq9XkTzNb1e1K7hwzRK/TXGbtdFr//+V/pp//Wcxv7h+4v7znnxUkjb66L+eqU2eG56Pr0T9f6i67pkH0+uUTPb2N5LrRevg5mj7OukltP06b3TdbU5fo/rx/P2E3T+9N6pXRdR72Ntrmscl3kM/Nh6XcAr8EoDv
base65:=V';
my $regex = qr/(?<!(base64).*)(?<![\/@#:\.])\bV\b(?![:#])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}