# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!(base64).*)(?<![\/@#:\.])\bV\b(?![:#])"
test_str = ("base64:= \"iVBORw0KGgoAAAANSUhEUgAAAyAAAAJzCAYAAAD3HXeFAAAgAElEQVR4nOy9W3bksI4ECOp6ET2n56dn/1u8yfkgAeJJUbaryo+IUy5nSiQIUuEEFIKU7f/7f/+fTkTUeydqjah3aq0RUSNqRNQ7ddk20Oc2bnO1Rq9XJ27SO9F1XdT7a/RrjfrrRURErbXZl8z7MQZRa9ewwfvneNyutUatNXq9XkTzNb1e1K7hwzRK/TXGbtdFr//+V/pp//\n\n\n"
"base64:=+V\n\n"
"V\n\n"
"base64:=V\n\n"
"base65 := \"iVBORw0KGgoAAAANSUhEUgAAAyAAAAJzCAYAAAD3HXeFAAAgAElEQVR4nOy9W3bksI4ECOp6ET2n56dn/1u8yfkgAeJJUbaryo+IUy5nSiQIUuEEFIKU7f/7f/+fTkTUeydqjah3aq0RUSNqRNQ7ddk20Oc2bnO1Rq9XJ27SO9F1XdT7a/RrjfrrRURErbXZl8z7MQZRa9ewwfvneNyutUatNXq9XkTzNb1e1K7hwzRK/TXGbtdFr//+V/pp//Wcxv7h+4v7znnxUkjb66L+eqU2eG56Pr0T9f6i67pkH0+uUTPb2N5LrRevg5mj7OukltP06b3TdbU5fo/rx/P2E3T+9N6pXRdR72Ntrmscl3kM/Nh6XcAr8EoDv\n\n"
"base65:=V")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.