const regex = /\b(C(hief )?E(xecutive )?O(fficer)?|Direct(eur|rice)\sGénérale?|Founder|General\sManager|Owner|President|Partner|P(r[ée]sidente?)?D(irect(eur|rice))?G([ée]n[ée]rale?))\b(?!.*\b(Logistic|Industry|Industrial|Construction|Transport)\b)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(C(hief )?E(xecutive )?O(fficer)?|Direct(eur|rice)\\sGénérale?|Founder|General\\sManager|Owner|President|Partner|P(r[ée]sidente?)?D(irect(eur|rice))?G([ée]n[ée]rale?))\\b(?!.*\\b(Logistic|Industry|Industrial|Construction|Transport)\\b)', 'gmi')
const str = `CEO at TechCorp
General Manager of Construction Ltd
Chief Executive Officer at GreenTech
Directeur Général, Retail Co.
Directrice Générale, Fashion House
President of Logistics Firm
Founder of Innovative Solutions
Partner at Finance Group
COO at Healthcare Inc.
Owner of a Design Studio
CTO at Software Development Firm
President of HR Solutions
Junior Consultant at Business Partners
Freelance Marketing Advisor
Investor in Tech Startups
General Manager at Transport Services
CEO of Logistics & Supply
Founder of Non-Profit Organization
Chief Executive Officer at Construction Co.
Partner at Talent Acquisition Firm
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}