import Foundation
let pattern = #"\b(C(hief )?E(xecutive )?O(fficer)?|Direct(eur|rice)\sGénérale?|Founder|General\sManager|Owner|President|Partner|P(r[ée]sidente?)?D(irect(eur|rice))?G([ée]n[ée]rale?))\b(?!.*\b(Logistic|Industry|Industrial|Construction|Transport)\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
CEO at TechCorp
General Manager of Construction Ltd
Chief Executive Officer at GreenTech
Directeur Général, Retail Co.
Directrice Générale, Fashion House
President of Logistics Firm
Founder of Innovative Solutions
Partner at Finance Group
COO at Healthcare Inc.
Owner of a Design Studio
CTO at Software Development Firm
President of HR Solutions
Junior Consultant at Business Partners
Freelance Marketing Advisor
Investor in Tech Startups
General Manager at Transport Services
CEO of Logistics & Supply
Founder of Non-Profit Organization
Chief Executive Officer at Construction Co.
Partner at Talent Acquisition Firm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)