using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(yesterday|\d+(?=\s+\w+)|\w+(?=\s+year))\s*(\w*)$";
string input = @"Yesterday
Last 7 Days
Last 30 Days
This Year
Last Year";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}