re = /(yesterday|\d+(?=\s+\w+)|\w+(?=\s+year))\s*(\w*)$/im
str = 'Yesterday
Last 7 Days
Last 30 Days
This Year
Last Year'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end