$re = '/(yesterday|\d+(?=\s+\w+)|\w+(?=\s+year))\s*(\w*)$/im';
$str = 'Yesterday
Last 7 Days
Last 30 Days
This Year
Last Year';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);