#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(?!(regular\s*expression)$)[a-z](?:[ ()'.a-z-]*[a-z()])$"
Local $sString = "RegularExpression" & @CRLF & _
"RegularEXPression" & @CRLF & _
"aRegularExpression" & @CRLF & _
"RegularExpression2" & @CRLF & _
"a b () c d )" & @CRLF & _
"a b () c d - )"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")