re = /(?i)^(?!(regular\s*expression)$)[a-z](?:[ ()'.a-z-]*[a-z()])$/m
str = 'RegularExpression
RegularEXPression
aRegularExpression
RegularExpression2
a b () c d )
a b () c d - )'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end