$re = '/(?i)^(?!(regular\s*expression)$)[a-z](?:[ ()\'.a-z-]*[a-z()])$/m';
$str = 'RegularExpression
RegularEXPression
aRegularExpression
RegularExpression2
a b () c d )
a b () c d - )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);