# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\w)([A-Za-z])\./\1/gm;t' <<< "U.S.S.R. line-continued
u.s.s.r. line-continued
U.S.S.R. Title Case
end-of-sentence. New-sentence
end-of-sentence."