#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\w)([A-Za-z])\."
Local $sString = "U.S.S.R. line-continued" & @CRLF & _
"u.s.s.r. line-continued" & @CRLF & _
"U.S.S.R. Title Case" & @CRLF & _
"end-of-sentence. New-sentence" & @CRLF & _
"end-of-sentence."
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)