import re
regex = re.compile(r"(?<!\w)([A-Za-z])\.", flags=re.MULTILINE)
test_str = ("U.S.S.R. line-continued\n"
"u.s.s.r. line-continued\n"
"U.S.S.R. Title Case\n"
"end-of-sentence. New-sentence\n"
"end-of-sentence.")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)