#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^master$|^main$|^release.*"
Local $sString = "release" & @CRLF & _
"master" & @CRLF & _
"main" & @CRLF & _
"release-foo" & @CRLF & _
"my-release" & @CRLF & _
"user/ianjirka/release-foo" & @CRLF & _
"user/ianjirka/foo" & @CRLF & _
"user/ianjirka/main" & @CRLF & _
"user/ianjirka/master" & @CRLF & _
"user/ianjirka/release" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")