import re
regex = re.compile(r"^master$|^main$|^release.*", flags=re.MULTILINE)
test_str = ("release\n"
"master\n"
"main\n"
"release-foo\n"
"my-release\n"
"user/ianjirka/release-foo\n"
"user/ianjirka/foo\n"
"user/ianjirka/main\n"
"user/ianjirka/master\n"
"user/ianjirka/release\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")