package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^master$|^main$|^release.*`)
var str = `release
master
main
release-foo
my-release
user/ianjirka/release-foo
user/ianjirka/foo
user/ianjirka/main
user/ianjirka/master
user/ianjirka/release
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}