package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(\d+)(:[A-Z0-9-]+(?: [A-Z0-9-]+)*)?:(\d+(?:\.\d{1,2})?)$`)
var str = `12:aaa:12.31
56:a s f:15
34:45.8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}