re = /^(\d+)(:[A-Z0-9-]+(?: [A-Z0-9-]+)*)?:(\d+(?:\.\d{1,2})?)$/mi
str = '12:aaa:12.31
56:a s f:15
34:45.8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end