const regex = /^(\d+)(:[A-Z0-9-]+(?: [A-Z0-9-]+)*)?:(\d+(?:\.\d{1,2})?)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)(:[A-Z0-9-]+(?: [A-Z0-9-]+)*)?:(\\d+(?:\\.\\d{1,2})?)$', 'gmi')
const str = `12:aaa:12.31
56:a s f:15
34:45.8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}