using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\baaa accounting system default.*?group tacacs\+";
string input = @"aaa accounting system default
action-type start-stop
group tacacs+
aaa accounting system default start-stop group tacacs+";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}