$re = '/(?s)\baaa accounting system default.*?group tacacs\+/';
$str = 'aaa accounting system default
action-type start-stop
group tacacs+
aaa accounting system default start-stop group tacacs+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);