package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\baaa accounting system default.*?group tacacs\+`)
var str = `aaa accounting system default
action-type start-stop
group tacacs+
aaa accounting system default start-stop group tacacs+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}