# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<p).*?(<\\/A>)/$1>/g;t' <<< " <p TITLE=\"Super Sent., lib. 3 d. 6 q. 1 a. 2 arg. 3\"><A NAME=\"8220\"><SPAN CLASS=\"ref\">[8220] Super Sent., lib. 3 d. 6 q. 1 a. 2 arg. 3 </SPAN></A>"