import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<\\d+>([\\S]+)\\s([\\S]+)\\saccess-nginx\\:\\s([\\S\\.]+)\\s\\-+\\s([\\S]+)\\s\\-\\s\\-\\s\\[([\\S\\s]+)\\]\\s\\\"((\\\\.|[^\\\"])*)\\\"\\s([\\S]+)\\s([\\S]+)\\s\\\"((\\\\.|[^\\\"])*)\\\"\\s\\\"((\\\\.|[^\\\"])*)\\\"\\s\\\"((\\\\.|[^\\\"])*)\\\"";
final String string = "<182>2019-08-05T14:17:25.000000+00:00 hqchweb012 access-nginx: 10.56.40.201 - - - - [05/Aug/2019:14:17:16 +0200] \"GET /il/he/customer/account/getminilogindata HTTP/1.1\" 200 190 \"https://www.nespresso.com/il/he/gifting\" \"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36 OPR/60.0.3255.109\" \"212.143.212.222, 2.16.187.63, 23.57.69.121\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}