import Foundation
let pattern = #"^<\d+>([\S]+)\s([\S]+)\saccess-nginx\:\s([\S\.]+)\s\-+\s([\S]+)\s\-\s\-\s\[([\S\s]+)\]\s\"((\\.|[^\"])*)\"\s([\S]+)\s([\S]+)\s\"((\\.|[^\"])*)\"\s\"((\\.|[^\"])*)\"\s\"((\\.|[^\"])*)\""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<182>2019-08-05T14:17:25.000000+00:00 hqchweb012 access-nginx: 10.56.40.201 - - - - [05/Aug/2019:14:17:16 +0200] "GET /il/he/customer/account/getminilogindata HTTP/1.1" 200 190 "https://www.nespresso.com/il/he/gifting" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36 OPR/60.0.3255.109" "212.143.212.222, 2.16.187.63, 23.57.69.121""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)